Canada Redemption Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Feb 19, 2020 - 15:21 PST
Identified
Our team is aware of redemption delays that began 2/13/2020. We are currently investigating the source of the issue.
Posted Feb 14, 2020 - 12:55 PST
This incident affected: Seller Redemptions (Canada Redemptions).