Canada Shipping Label Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 11:57 PDT
Monitoring
Shipping labels should be sent via email shortly.
Posted Sep 20, 2021 - 10:11 PDT
Identified
Shipping label generation is currently experiencing a delay. Rest assured, your shipping label will automatically be sent to your email once the issue is resolved; no action is required on your part. Thank you for your patience!
Posted Sep 20, 2021 - 09:00 PDT
This incident affected: Shipping (Canada Shipping).