US Redemption Delays
Incident Report for Poshmark
Resolved
All redemptions should now be processed within regular processing times.
Posted Sep 30, 2021 - 10:54 PDT
Identified
Redemptions may be experiencing some delay due to a connectivity issue with our banking partner. Rest assured we are working with them directly to resolve the issue as soon as possible.
Posted Sep 28, 2021 - 11:00 PDT
This incident affected: Seller Redemptions (United States Redemptions).