Canada Shipping Delays

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 12:38 PST

Monitoring

Canada Post is currently experiencing operational delays in deliveries due to inclement weather and snow. We are actively monitoring the situation and apologize for any inconvenience this causes.
Posted Jan 15, 2026 - 17:07 PST
This incident affected: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications, User Communications (Push Notifications, Email Notifications), Seller Redemptions (Canada Redemptions), Posh Authenticate (Canada Posh Authenticate), and Shipping (Canada Shipping).