Canada Posh Authenticate

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 13:01 PST

Update

We are continuing to monitor for any further issues.
Posted Jan 12, 2026 - 10:17 PST

Monitoring

Due to increased volumes, our authentication processing times have extended beyond the normal 1-3 business days. Please allow up to 7 business days from when we receive your shipment to verify your order. Thanks for your patience and understanding.
Posted Nov 24, 2025 - 11:51 PST
This incident affected: User Communications (Push Notifications, Email Notifications), Seller Redemptions (Canada Redemptions), Posh Authenticate (Canada Posh Authenticate), Shipping (Canada Shipping), and Support Communications.