Canada Post Shipping Labels
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 10:18 PDT
Investigating
We are currently investigating reports of some shipping labels being refused by Canada Post. If you are experiencing any issues with shipping packages, please contact our Support team for further assistance: support.poshmark.ca/s/contactsupport
Posted Oct 12, 2021 - 16:06 PDT
This incident affected: Shipping (Canada Shipping).