Shipping Label Outage

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 11:45 PST

Monitoring

Canada Post is experiencing a label outage. Rest assured, your shipping label will automatically be sent to your email once the issue is resolved; no action is required on your part.

Purolator labels are generating as normal.
Posted Feb 27, 2026 - 09:27 PST
This incident affected: Shipping (Canada Shipping).