CA Posh Authenticate Order Processing
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted May 26, 2022 - 16:47 PDT
Monitoring
Due to increased volumes, our authentication processing times have extended beyond the normal 1-2 business days. Please allow up to 4-5 business days from when we receive your shipment to verify your order.
Posted May 24, 2022 - 09:28 PDT
This incident affected: Posh Authenticate (Canada Posh Authenticate).