US Redemption delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Oct 24, 2019 - 08:14 PDT
Update
Due to the rapid growth of our community and business over the past month, our payment and redemption queues became backlogged over the holiday weekend. As a result, some redemptions requested between October 11-15 are processing slower than normal.

As of now, we’ve successfully processed all delayed redemptions with our banking partner, and redemptions can be expected by Wednesday, October 23, or earlier, depending on your financial institution.
Posted Oct 18, 2019 - 11:53 PDT
Monitoring
Due to a high volume of redemptions requested over the holiday weekend, some redemptions are processing slower than normal if they were requested between 10/11 and 10/15. Our team is aware and has confirmed that these redemptions are now successfully processing on a rolling basis. We apologize for the delay
Posted Oct 17, 2019 - 21:41 PDT
This incident affected: Seller Redemptions (United States Redemptions).