USPS Shipping Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 11:06 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 28, 2021 - 11:06 PDT
Monitoring
USPS has temporarily suspended operations in parts of the country due to effects of Hurricane Ida, as well as wildfires throughout California. Rest assured, we are actively monitoring the situation for further updates. Please check USPS' service alerts for any impacts to their operations in your area: https://about.usps.com/newsroom/service-alerts/
Posted Sep 20, 2021 - 12:00 PDT
This incident affected: Shipping (United States Shipping).