Canada Post Service Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 21:00 PDT
Update
We are continuing to monitor for any further issues.
Posted Sep 21, 2020 - 20:59 PDT
Monitoring
Canada Post has temporarily paused mail and parcel services in parts of British Columbia due to fire risks. More information on if your area has been impacted by these delays can be found here: https://www.canadapost.ca/cpc/en/our-company/news-and-media/service-alerts.page

We are actively monitoring the situation and apologize for any inconvenience this may have caused!
Posted Sep 15, 2020 - 08:17 PDT
This incident affected: Shipping (Canada Shipping).