Canada Post Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jul 24, 2023 - 09:46 PDT
Monitoring
Canada Post is currently experiencing some operational delays in pickup & delivery due to wildfires in the Alberta area.

More information on if your area has been impacted by these delays can be found here: https://www.canadapost.ca/cpc/en/our-company/news-and-media/service-alerts.page

We are actively monitoring the situation and apologize for any inconvenience this causes.
Posted May 08, 2023 - 09:53 PDT
This incident affected: Shipping (Canada Shipping).