Shipping Label Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Apr 03, 2019 - 08:44 PDT
Update
We are continuing to monitor for any further issues.
Posted Apr 03, 2019 - 08:43 PDT
Monitoring
We are currently experiencing temporary delays for shipping labels. Our team is actively monitoring the situation.
Posted Apr 03, 2019 - 07:56 PDT