Delivery Delays Due to Southern California Wildfires
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jan 21, 2025 - 09:58 PST
Monitoring
We are aware of the ongoing wildfires affecting several areas in Southern California, including Malibu, Santa Monica, Los Angeles, Pasadena, and San Fernando. Sellers shipping orders from these impacted regions (Palisades, Eaton, and Hurst wildfire zones) may experience delays in the delivery of mail and packages due to disruptions caused by the natural disaster.
We appreciate your patience and understanding as local authorities work to manage the situation and restore normal shipping services.
Posted Jan 10, 2025 - 10:30 PST
This incident affected: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications, Seller Redemptions (United States Redemptions), Posh Authenticate (United States Posh Authenticate), and Shipping (United States Shipping).