Shipping Label Delay
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 16:09 PDT
Identified
Shipping label generation is currently experiencing a delay. Rest assured, your shipping label will automatically be sent to your email once the issue is resolved; no action is required on your part.

Thank you for your patience!
Posted Oct 21, 2021 - 13:19 PDT
This incident affected: Shipping (United States Shipping).