Canada: Redemption Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jan 28, 2020 - 15:32 PST
Investigating
Our team is aware of redemption delays that began 1/21/2020. We are currently investigating for the source of the issue.
Posted Jan 24, 2020 - 15:05 PST
This incident affected: Seller Redemptions (Canada Redemptions).