Canada Shipping

Incident Report for Poshmark

Update

Monitoring: Mail services are currently experiencing some operational delays due to active wildfire activity. We are monitoring the situation and apologize for any inconvenience this causes.
Posted Jun 03, 2025 - 10:05 PDT

Monitoring

The Canadian Union of Postal Workers (CUPW) has initiated a strike action with a national overtime ban for CUPW-represented Canada Post employees effective May 23rd. At this time Canada Post will continue to operate, but customers should expect delays. To ship your orders during this time, we have launched the option to ship with Purolator at no additional cost. We strongly encourage you to use this option to ship your orders.

For details on how to get started, visit: https://support.poshmark.ca/s/article/Shipping-with-Purolator?language=en_US
Posted May 23, 2025 - 08:29 PDT
This incident affects: Shipping (Canada Shipping).