Weather Delays

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted Feb 06, 2020 - 07:54 PST

Update

Service remains delayed in parts of Newfoundland due to the effects of the snowstorm. We are actively monitoring the situation for further updates.
Posted Jan 24, 2020 - 10:28 PST

Update

We are continuing to monitor for any further issues.
Posted Jan 23, 2020 - 12:16 PST

Monitoring

Canada Post has temporarily suspended operations in parts of Newfoundland due to the effects of the snowstorm. Rest assured, we are actively monitoring the situation for further updates.
Posted Jan 23, 2020 - 12:16 PST
This incident affected: Shipping (Canada Shipping).