Scheduled Maintenance – USPS QR Code Outage

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted May 07, 2025 - 08:53 PDT

Monitoring

USPS will be conducting scheduled maintenance on their systems on Tuesday, May 6 starting at 6PM PT, with an expected duration of up to 3 hours. During this time, QR code-based shipping labels may not be available or may fail to scan properly. We recommend using standard printable shipping labels during this window to avoid disruptions.
We appreciate your patience and understanding while USPS completes this update.
Posted May 05, 2025 - 10:13 PDT
This incident affected: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications, Seller Redemptions (United States Redemptions, Canada Redemptions), Posh Authenticate (United States Posh Authenticate, Canada Posh Authenticate), and Shipping (United States Shipping, Canada Shipping).