Shipping Label Delay
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 03:46 PDT
Investigating
Shipping label generation is currently experiencing a delay. Rest assured, your shipping label will automatically be sent to your email once the issue is resolved; no action is required on your part.
Posted Jul 18, 2024 - 23:46 PDT
This incident affected: Shipping (United States Shipping).