USPS Shipping Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jul 20, 2021 - 09:56 PDT
Monitoring
We are continuing to monitor USPS shipping delays. USPS is experiencing unprecedented package volumes and limited employee availability due to the impacts of COVID-19. At this time, your order may be delayed if tracking for the order shows “In Transit, Arriving Late.”

Rest assured, your order should be delivered to you soon. However, if tracking has stopped and you have not received any additional updates 10 days from the last tracking update, please contact Poshmark Support. We’d be happy to take a further look!

You can find FAQs related to current USPS shipping delays here: https://support.poshmark.com/s/article/USPS-Shipping-Delays
Posted Jul 13, 2021 - 11:00 PDT
This incident affected: Shipping (United States Shipping).