Canda Shipping

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 08:31 PDT

Update

Monitoring: Mail services are currently experiencing some operational delays due to active wildfire activity. We are monitoring the situation and apologize for any inconvenience this causes.
Posted Jun 24, 2025 - 17:02 PDT

Monitoring

Canada Post is planning a maintenance outage from 6:00 PM EST on June 30th through 7:00 AM EST on July 2nd. During this time, no new Canada Post labels will be generated on Poshmark. Once the maintenance window ends, all Canada Post labels will be generated for any impacted orders and for all new orders going forward. We apologize for the inconvenience and appreciate your patience.
Posted Jun 24, 2025 - 17:02 PDT
This incident affected: Shipping (Canada Shipping).