Scheduled Maintenance Notice
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Aug 30, 2024 - 10:35 PDT
Monitoring
Our Payment Processor has scheduled maintenance on August 29th, from 10:00 PM to 11:00 PM PST.

During this time, payment processing may be temporarily unavailable. We recommend completing any urgent transactions before or after the maintenance window. We appreciate your patience.
Posted Aug 29, 2024 - 09:48 PDT