Higher Support Volumes: Expect Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jan 23, 2025 - 14:49 PST
Monitoring
We are currently experiencing higher volumes and longer response times. For quicker assistance, please visit the Poshmark Support Center (www.support.poshmark.com) to find answers to your questions.
Posted Jan 21, 2025 - 09:25 PST
This incident affected: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications, Seller Redemptions (United States Redemptions), Posh Authenticate (United States Posh Authenticate), and Shipping (United States Shipping).