USPS Closures on January 9, 2025, and Potential Shipping Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jan 10, 2025 - 10:30 PST
Monitoring
All USPS post offices will be closed on Thursday, January 9, 2025, in observance of a National Day of Recognition for former President Jimmy Carter.

Please anticipate potential shipping delays during this time. USPS operations will resume as normal on Friday, January 10, 2025
Posted Jan 06, 2025 - 10:57 PST
This incident affected: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications, Seller Redemptions (United States Redemptions), Posh Authenticate (United States Posh Authenticate), and Shipping (United States Shipping).