Canada Post Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 09:46 PDT
Monitoring
Canada Post is currently experiencing some operational delays in pickup & delivery due to active wildfires across the country. We are monitoring the situation and apologize for any inconvenience this causes.
Posted Jul 22, 2024 - 11:52 PDT
This incident affected: Shipping (Canada Shipping).