Canada Post Strike Ending
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jan 31, 2025 - 10:24 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 23, 2025 - 14:51 PST
Monitoring
Canada Post services will resume on Tuesday, December 17th at 8:00 AM local time, with post offices reopening and delivery services commencing. The national strike caused significant impacts across their operations, and Canada Post will be working to recover as quickly as possible. As a result, please expect some delays as they catch up, process, and deliver mail and parcels across the country.
Posted Dec 16, 2024 - 14:17 PST
This incident affected: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications, Seller Redemptions (Canada Redemptions), Posh Authenticate (Canada Posh Authenticate), and Shipping (Canada Shipping).