Canada Post Strike Announced
Incident Report for Poshmark
Update
We are continuing to monitor for any further issues.
Posted Nov 15, 2024 - 09:09 PST
Monitoring
The Canadian Union of Postal Workers (CUPW) issued a nationwide strike to Canada Post, beginning November 15, 2024 at 12:01 AM ET. While a strike may lead to shipping delays, Poshmark is fully committed to continuing operations and will do everything we can to minimize disruption to our community.

In areas affected by a strike, post offices may temporarily be closed, and parcel delivery and pick-up may be delayed. To check the latest updates on Canada Post’s labour negotiations and to see if your area is affected at any point, visit here:
https://www.canadapost-postescanada.ca/cpc/en/our-company/news-and-media/corporate-news/negotiations-list.page

Please be aware that we’ve extended the shipping window to 10 days to account for this.

We will continue to update this page as more information becomes available. Thank you for your understanding.
Posted Nov 12, 2024 - 09:52 PST
This incident affects: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications and Shipping (Canada Shipping).