PayPal and Venmo Checkout Errors
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 17:03 PST
Monitoring
Payments at checkout may experience an error using PayPal or Venmo as our payments processor is currently experiencing delays. In the meantime, we suggest using another form of payment at checkout.
Posted Feb 20, 2021 - 16:08 PST
This incident affected: Checkout.