Delhivery Shipping Delays and Label Generation Failures
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 08:13 PST
Monitoring
Due to operational constraints, some pincodes may be blocked from creating shipping labels for orders. We are monitoring the situation for further updates.

Additionally, due to floods and heavy rain Tamil Nadu, there are interrupted or delayed services for Delhivery including parcel pick-up and delivery.
Posted Nov 22, 2021 - 08:00 PST
This incident affected: Shipping (India Shipping).