USPS Weather Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 09:09 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 03:50 PDT
Monitoring
Weather events in the South, Southeast, and Central U.S. related to Hurricane Beryl are impacting the processing, transportation, and delivery of packages. Please allow additional time for the final delivery of your item. Rest assured, we are actively monitoring the situation for further updates.
Posted Jul 17, 2024 - 13:14 PDT
This incident affected: Shipping (United States Shipping).