Weather Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Sep 09, 2019 - 11:17 PDT
Monitoring
USPS has temporarily suspended deliveries in parts of the Southeast region of the US due to Hurricane Dorian. Rest assured, we are actively monitoring the situation for further updates.
Posted Sep 03, 2019 - 13:31 PDT
This incident affected: Shipping (United States Shipping).