Shipping Label Issues
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Mar 01, 2020 - 10:17 PST
Monitoring
Our team is monitoring the stability of shipping label generation. Any delayed shipping label(s) will automatically be sent to your email as this issue is resolved; no action is required on your part.
Posted Feb 29, 2020 - 20:23 PST
Identified
Shipping label generation is currently experiencing a delay. Rest assured, your shipping label will be automatically sent to your email once the issue is resolved; no action is required on your part.

Thank you for your patience!
Posted Feb 29, 2020 - 19:04 PST
This incident affected: Shipping (United States Shipping).