Canada Post Shipping Label Outage

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 11:04 PST

Monitoring

Our team is aware of the errors affecting Canada Post shipping label generation. We are actively working to implement a fix. Once the issue is resolved, your shipping label will automatically be sent to your email—no action is required on your part.

We appreciate your patience and will continue to provide updates as soon as more information becomes available. Thank you for your understanding!
Posted Feb 04, 2025 - 16:42 PST
This incident affected: Poshmark Mobile Apps, Poshmark Website, Checkout, Support Communications, Seller Redemptions (Canada Redemptions), Posh Authenticate (Canada Posh Authenticate), and Shipping (Canada Shipping).