USPS Weather Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 09:12 PST
Monitoring
Due to power outages that are widespread as a result of severe winter storms that are bringing snow, freezing rain and bitter temperatures to some parts of the country, there may be interrupted service for USPS. Please check USPS' service alerts for any impacts to their operations in your area: https://about.usps.com/newsroom/service-alerts/
Posted Feb 23, 2021 - 13:30 PST
This incident affected: Shipping (United States Shipping).