Website Delays
Incident Report for Poshmark
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 19:12 PDT
Monitoring
Website delays have been resolved as of 6:30 PM PST. Our team is monitoring for stability.
Posted Mar 30, 2020 - 18:32 PDT
Investigating
Our website is currently experiencing delays. Our team is aware of the issue and is further investigating.
Posted Mar 30, 2020 - 17:00 PDT
This incident affected: Poshmark Website.