Canada Post Weather Delays

Incident Report for Poshmark

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 16:02 PST

Update

We are continuing to monitor for any further issues.
Posted Feb 18, 2025 - 11:04 PST

Monitoring

Canada Post is currently experiencing some operational delays in pickup & delivery due to inclement weather and snow. We are actively monitoring the situation and apologize for any inconvenience this causes. More information can be found here: https://www.canadapost.ca/cpc/en/our-company/news-and-media/service-alerts.page
Posted Feb 03, 2025 - 15:29 PST
This incident affected: Shipping (Canada Shipping).